SUMMARY: Java JDK not y2k compliant

From: Brown, Melissa (
Date: Thu Dec 16 1999 - 16:33:03 CST

The Java JDK 1.1.3 version of is bundled with the Solaris 2.6 version.

The upgrade isn't difficult, just have to make sure that you have about nine
patches up-to-date and the right font package before starting.
There were two of the nine patches that weren't in the 2.6 Recommended
cluster. One of those didn't have a "required" patch, but the special
instructions indicated that another patch should be installed first. (hmmmm)
That "third" patch is part of the 2.6 Recommended cluster.

I did the 1.2.1_04 install.
Note that the symbolic link for /usr/java that points to the old version (in
my case, /usr/java1.1), needs to be replaced it with /usr/java link that
points to newly installed (in my case, /usr/java1.2)
The link from /usr/bin/java points to /usr/java/bin/java, so if you upgrade
and you still get the old version when you do a java -version, check your

Here's the url that SunScan gives you for the JDK/JRE. It gives the
background and has the links to the downloads:

Thanks to about a dozen people, their names are listed with their comments.
Some excellent, informative comments!!!!! Those comments follow the my
original plea, I mean request, for help.


-----Original Message-----
I've got 4 newly installed Solaris 2.6/sparc systems patched with the
recommended security and y2k patches. They are all newly installed with
the Netscape Enterprise Server 3.6SP2.
I've just run SunScan on them, thinking they would come out clean, and
got a warning:
>The Java JDK installed in the standard path for this
>system is NOT Year 2000 compliant. If you are using this
>JDK to develop or run Java applications or applets, you should
>upgrade to a compliant version.
>Installed: 1.1.3n:1997.06.26
>Upgrade to: 1.1.7_08a, 1.1.8_09a, 1.2.1_03a or 1.2.1_04
>For more information on Java JDK Year 2000 compliant
>versions, please see:
I haven't installed the JDK/JRE separately and it might be installed
with the OS, but I think it was installed with the Netscape Communicator
4.7 or the Browser. I'm not sure and that's why I'm posting this here.
Maybe it'll help someone else when I post a summary.
Will the NES 3.6SP2 bomb out if I upgrade the Java JDK and JRE to the
1.2.1_04 as the Solaris recommends????
If the JDK is installed withe OS, why isn't aren't the patches required
for upgrade in the 2.6 Recommended cluster?
I can't find anything about this.... I can't beleive that no one has
that the wrong version is being installed and not patched. I've gone
through newsgroups and y2k partnership dialogues and all sorts of stuff
trying to find something about it.
Hopefully someone will answer this and set me straight because right now
I'm thinking that one of the two developers needs to alert people who
hasn't stumbled on it like I did.

I know for sure that JDK 1.1.7 is y2k, and works with NES3.6, I haven't
tried with 1.2.1

> If the JDK is installed withe OS, why isn't aren't the patches required > for upgrade in the 2.6 Recommended cluster?

That's a good question, but apparently they aren't.. I'm dealing with that today. Best of luck.

sasha eysymontt - sage@3sheep.COM ---------------------------------------------------------------------------- -- JDK is installed with OS. You just need to get the compliant version, removed the OS version, and install the compliant version. It is easier than you think. I have done this. Hope this helps. ---------------------------------------------------------------------------- -- I went through this a little while ago. You need to get to 1.2.1_04 THAT IS THE ONLY ONE COMPLIANT.

hope that helps Dolores Capers [] ---------------------------------------------------------------------------- -- It was part of the OS -- see ( pkginfo | egrep Java ) system SUNWjvdem JavaVM demo programs system SUNWjvdev JavaVM developers package, includes javac, javah, and javap system SUNWjvjit Java JIT compiler system SUNWjvman JavaVM man pages system SUNWjvrt JavaVM run time environment

The 5 packages above are 1.1.x JDK packages. They are installed on 2.6 and 2.7 by default. The following are 1.2 packages: system SUNWj2dbg JDK 1.2 debug binaries system SUNWj2dem JDK 1.2 demo programs system SUNWj2dev JDK 1.2 development tools system SUNWj2man JDK 1.2 man pages system SUNWj2rt JDK 1.2 run time environment

They are installed by default only in Sol 8.

|Will the NES 3.6SP2 bomb out if I upgrade the Java JDK and JRE to the |1.2.1_04 as the Solaris recommends????

Not sure about this ... Your safest bet would be to just install the 1.1.x packages from the web,... Both 1.1.x and 1.2.x can be installed on the same machine. The default is the last one installed on Sol 7(links are created by install) I think its the 1.1.x ver on 2.6.

|If the JDK is installed withe OS, why isn't aren't the patches required |for upgrade in the 2.6 Recommended cluster?

Not sure, probably because we can't tell which JDK's might be needed...

Chris Phillips, Chris.Phillips@Sun.Com ---------------------------------------------------------------------------- -- Starting with Solaris 2.6 the JDK and JRE are bundled with the OS. I have no clue why Sun does not bundle the y2k patches for thise produts with their y2k patch clusters. Just upgrade both. NES should come with its own Java implementation (as does Netscape Communicator).

Michael Hocke [] ---------------------------------------------------------------------------- -- Solaris 2.6 ships with JDK 1.1.3

Mark Wilcox [] ---------------------------------------------------------------------------- -- I'm not shure I have this completely right, but the way I understand it....

JDK/JRE 1.1.7_08a is the latest Java 1.1 that is completely API compatible with 1.1.3. 1.1.8_09a has changed something that *may* break apps. So if you don't know which API's your apps use and want to be absolutely sure, use 1.1.7. The change in API is date related AFAIK.

I think the difference between 1.2.1_03a and 1.2.1_04 may be similar. I have never looked into it.

The jump from 1.1 to 1.2 is major. So if you have apps that use Java, make shure you check that they are compatible with Java 1.2 (also known as the Java 2 platform).

If you don't want to worry about compatibility, install 1.1.7_08a now, hand in your y2k compliance report, and then start looking into upgrading to 1.2 when you have some spare time.

The readme file in the distribution has the neccesary pkgrm and pkgadd commands to remove the old package and install the new one.

Birger Wathne ---------------------------------------------------------------------------- -- JDK comes with full Installation of Solaris as well. We had the same trouble as you, and our Solution was to upgrade to 1.1.8_09a with apropriate Patches. 5.5.1: 103566-43, 103640-28 (Minimum), 103627-10 5.6: 105181-15, 105210-19, 105284-25, 105490-07, 105568-13, 105633-21, 105669-07 106040-11, 106409-01 5.7: 106980-05, 107078-10, 107607-01, 107636-01

regards Dieter Wurm [] ---------------------------------------------------------------------------- -- JDK 1.1.3 is installed by default with Solaris 2.6.

I would not upgrade to Java 1.2.x as it is still fairly new and there are compatibility issues. go with 1.1.8 as 1.1.7 has a number of issues too. If you are not using any pages which use Java, then NES3.6SP2 should not even 'notice' that the JDK has changed.

We are using JDK 1.1.6 with NES3.6SP2 (due to in house reasons for needing 1.1.6). And 1.1.8 on other machines running Apache. We actually need a JDK 1.1.6 or greater as we develop Java based software.

As to why the patches don't include a JDK, I don't know. I guess it is because of compatibility issues. Different versions of Java have quirks (not to mention the difference between the current 'reference' java implementation and the production implementation...).

Basically, if the version of Java you use is not critical, I would say go with 1.1.8_09a! -- Michael Miller, ---------------------------------------------------------------------------- -- Java is installed with the OS, but as a separate product the upgrade is released separately from the OS. The JVM stuff that comes with Netscape is competely separate from Solaris' version.

If you are not using java (i.e. not compiling and writing your own applets) then you could simply remove it:

pkgrm SUNWjvdem SUNWjvman SUNWjvdev SUNWjvjit SUNWjvrt

If you do need the java developement stuff then you can simply download the appropriate version (I used 1.1.8a) and follow the installation instructions.

I'm guessing the patches aren't included in the recommended/y2k bundles because Java is being treated as a separate product similar to SDS, AdminSuite, Workshop, etc.

John T. Douglass, ---------------------------------------------------------------------------- --

This archive was generated by hypermail 2.1.2 : Fri Sep 28 2001 - 23:13:35 CDT